Home » WordPress Version 5.5 is Breaking Sites And Plugins, How to fix it?
Technology Uncategorized

WordPress Version 5.5 is Breaking Sites And Plugins, How to fix it?

WordPress Version 5.5 is Breaking Sites And Plugins, How to fix it?

Since WordPress version 5.5 updates thousands of the websites that are built on this CMS have been broken. One of the reasons is that with WP 5.5, it doesn’t support jQuery Migrate anymore which affects almost 10,000 websites. The second reason due to which other sites are crashing after updating to 5.5 is how the theme handles pagination.

jQuery Migrate and WordPress 5.5

With the 5.5 updates, WordPress has ruled out the JavaScript library which is called jQuery due to which thousands of WordPress publisher’s websites are broken.

WordPress Version 5.5 is Breaking Sites And Plugins, How to fix it?

If you don’t know then let us tell you that jQuery acts as a bridge between the older codes so that they can properly function in WordPress. Sadbhavana Diwas 2020

Even without updating to WordPress 5.5 many of the publishers are facing the issue with their old theme still working. Due to this error, the website’s features like make forms, search bars, and the drop-down menu won’t be working properly.

The reason behind JavaScript Error in WordPress 5.5

There are two reasons for this error, the first is some are using the old plugins and the second is some are using the old theme. Few publishers are also reported that they are having difficulties in publishing the articles and featured images as well.

One publisher said, “Your last update is a pure disaster. I used the classic editor plugin because your block editor is a full mess, and now it does not work anymore since your update. I can only edit in HTML mode and not in visual!

So I tried to publish my last article in your block editor, but impossible to add a featured image, I have a white page with “Featured image” title showing on the top and that is all.”

How to Fix jQuery Migrate Bug?

This error is easily fixable, the only thing you need to do check how much older is the plugin that you are using. If the plugin doesn’t get any update for the past one year or more then you might want to change it with the plugin is more up-to-date.

For other reasons too, it is good to use an updated and well-maintained plugin for security reasons.

To fix this issue, WordPress has launched a plugin called Enable jQuery Migrate Helper that will restore the full-functionality of your website.

About the author

Abhishek Sharma

Abhishek Sharma

I am an ambitious man on my way to analyze and explore the depths of Journalism and Content Writing.

2 Comments

Click here to post a comment

  • Greetings from Ohio! I’m bored to tears at work so I decided to browse your blog on my iphone during lunch break.

    I love the information you provide here and can’t wait to
    take a look when I get home. I’m amazed at how fast your blog loaded on my mobile ..
    I’m not even using WIFI, just 3G .. Anyways, good blog!